
BaseLiner Instructions

Introduction

The BaseLiner program is designed to convert raw Granier sensor data into sapflow 
readings. It can also be used to convert any other data of similar type - where the 
readings are relative to a baseline value.

Raw Granier sensor data indicate the temperature difference (delta-T) between a pair of 
thermistors, with the highest values (delta-T-max) measured during no-flow conditions 
(Granier 1985, 1987). The flow is calculated based on the difference between measured 
delta-T and expected delta-T-max. Since Delta-T-max is not constant, but varies over 
time due to ambient temperature variations, the challenge in converting raw Granier 
data is to establish an appropriate baseline - the "no-flow" value against which the 
current reading is compared and flow rate calculated.

BaseLiner accomplishes this by identifying no-flow conditions and setting baseline 
points at those times. The baseline is then calculated by linear interpolation between 
the points.

The data conversion process, therefore, involves the two steps of establishing a 
baseline for an appropriate chunk of data and then calculating the output based on the 
values of each data point and the corresponding baseline value.

During early research (Oren et. al. 1999), it was assumed that a no-flow condition 
occurs every night at pre-dawn. Based on this assumption, a baseline point was set 
every night at the delta-T-max. Versions 1 and 2 of BaseLiner were designed with this 
assumption in mind.

Later research (Oishi et. al. 2008) revealed that nighttime respiration does occur, so 
no-flow conditions only happen when certain environmental conditions are met.

In light of this new research, BaseLiner version 3 can be set to pre-select delta-T-max 
points on nights when zero-flow conditions are met. This feature aids quicker data 
conversion and helps to identify nocturnal sap flux. Delta-T-max points are selected if 
they meet the following criteria:
1) Nighttime data, characterized by low PAR.
2) Low-VPD conditions for at least a two-hour period.
3) Stable delta-T, where the standard deviation divided by the mean of a
two-hour period is lower than a specified threshold. The delta-T-max point is the 
largest value in a given night satisfying all three of these criteria.

This automated selection of delta-T-max points should be used with discretion. The 
BaseLiner program enables the user to move delta-T-max points easily and we suggest 
that delta-T-max points be moved if there is a higher daily delta-T outside the low-
VPD, nighttime conditions. Delta-T-max points should be added for any night where 
delta-T values exceed the projected baseline.

Input and Output



The program reads text files - space-delimited (*.asc), tab-delimited (*.txt) or comma-
delimited (*.csv, *.dat). Make sure you use the correct file extensions!

The data should be organized in columns. You may have labels in the first row of data 
- if not, the program will use the first row of data to label the columns. Any non-
numeric values past the first row are ignored and treated as missing data.

BaseLiner can output files in any of the three supported text formats.

Opening a file

Use the standard menu command or the file-open button on the toolbar. After opening 
the file, you will see the Settings dialog come up. This dialog allows you to label your 
data columns, and also to enable or disable automatic conversion.

If you do not want to deal with the settings right away, you can cancel out of this 
dialog, and return to it later. But we suggest that you make sure the conversion mode 
is the one you want - it is set to Automatic by default.

The Settings dialog is used for the following actions:

1) Set the conversion mode. Check the "VPD pre-process" box to enable automatic 
conversion. You will need to identify the VPD and PAR columns and set the minimum 
values in the appropriate boxes. Also, set the time criteria for stable delta-T in the 
"Minimum time intervals" box - this will depend on the frequency of your data, and 
should add up to 2 hours. Unchecking the "VPD pre-process" box will disable 
automatic conversion. Please note that PAR is used as an indicator of nighttime, 
therefore if you don't have actual PAR data, you can use something else. For example, 
net radiation, estimated light based on day length, or even a "square wave" where 
expected nighttime values are set to zero and expected daytime values are some 
arbitrary number greater than the threshold value. The threshold value must be 
adjusted if non-PAR data are used.

2) Define which columns can be converted, and which ones must be copied straight to 
the output file. If you do not check the "Do not convert" box for a column, it will be 
initially filled with blank output values. You will also be able to convert the data in 
that column. If you check the "Don't convert" box, you will not be able to convert the 
data in that column, and the existing data will be copied to the output file. This is 
what you need to do with date and time columns, for example.

3) Edit the column labels, or add labels if there are none. Labeling the columns may 
make it easier to identify the data channel you are working on.

4) Determine if you want the labels saved in the output file. Use the "Save labels in 
output" checkbox.

Main Interface

The program is mouse-driven, with plenty of keyboard shortcuts to increase the speed 
of conversion. The main interface area is the two-pane plot display. Each pane can 



show any of the data columns in your file (one at a time). However, only the top pane 
can be used for conversion. In this pane, you can select any data point by clicking on 
the plot, or any range of data points by clicking and dragging the mouse. When a 
range is selected, it is displayed in red in both panes. The plots can auto-scroll while 
dragging.

Immediately after opening a file, the contents of the first data column are plotted in 
both panes. You can choose which column to display in each pane by making a 
selection from the drop-down lists above the panes. The Labels button next to the lists 
opens up the Settings dialog, discussed in the previous section. The "show" checkbox 
shows the actual labels in the data lists. When unchecked, the data lists will show the 
column numbers instead.

The plots are auto-scaling by default. You can turn that off by entering the desired low 
and high value in the boxes to the left of each pane. The bottom pane also has a Ref 
checkbox, which makes a reference line appear across the pane at the value entered in 
the box immediately below it (0 by default).

The scrollbar below the panes allows you to display data that don't fit in the pane.

Below the panes you can look up some useful information about your data. On the left, 
the number of columns and rows in the file are displayed. As you move the mouse over 
the top pane, you can see the input, baseline and output values for the point under the 
cursor, along with the date and time for that point.

The equation used for the conversion is displayed just above the data lists. It can be 
edited by pressing the "Equation:" button. The default equation is appropriate for 
Granier sensor data, and produces output in grams per square meter per second (g/
(m^2*s)). You can enter equations made up of the standard arithmetic operators, the 
power operator (^) and parentheses ( ). All standard rules of precedence apply. Use "B" 
for the baseline value and "X" for the data value.

Menus

The File menu contains the standard “New”, “Open”, “Close”, “Save”, “Save As...” 
and “Exit” commands. The "New" command opens a new window, so that you can 
work on more than one file at a time, if desired. If you have opened more than one 
window, the "Close" command will only close the active window. The "Exit" 
command will close all windows.

The Edit menu contains “Undo”, “Select All”,  and “Clear”.

There is one level of "Undo" while editing data. If you interpolate or delete data, you 
can undo your last action. Undo cannot be used while converting data.

"Select All" selects the entire data column.

"Clear" deletes the selected data - replaces them with the "missing data" value.

The View menu allows you to zoom in on the plot or zoom out. The "Refresh" option 
repaints the plot. The "Settings…" option brings up the Settings dialog, discussed in 



the file opening section.

The Tools menu provides you with the options you need to edit and convert data.

"Mode change" toggles between three operating modes, discussed in detail in the 
section about converting data. The current mode is shown in the status bar. If auto 
conversion is enabled, this menu item will be disabled, and 

"View change" switches the display between unconverted and converted data. You can 
also do this by pressing the "View" button in the main window. The current view is 
shown in the status bar.

"Interpolate" does a linear interpolation within the selected data range.

"Convert" converts the selected data range. You can also do this by pressing the 
"Convert" button in the main window.

"Delete selection" replaces the selected range with the "missing values" number (as 
defined in the Options).

"Break one-click baseline" is used to end a one-click conversion sequence (more on 
this in the conversion section below).

The three “recalculate” options are used to recalculate the output values, for instance, 
if you decide to use a different equation. "Recalculate selection" only does this within 
the selected range, "Recalculate current" applies to the entire currently active data 
column, and "Recalculate all" applies to the entire data file.

"Options" brings up the options dialog (this can also be done by pressing the 
"Equation:" button.)

The Options Dialog allows you to change and save program settings. One of them is 
the conversion equation, discussed above.

The "date column" and "time column" determine which of your data columns the 
program reads to display the date and time for the current data point or data selection. 
These are displayed in the main window right above the top pane, along with the 
values for the beginning and end of the selected data range.

The VPD and PAR settings and "Minimum time intervals" are identical to the ones in 
the Settings dialog (see above).

The "Number for missing values" should be set to whatever your data logger uses to 
indicate bad readings. This is usually 99999 for Campbell loggers and 6999 for Delta-
T loggers. If your input file contains some other notation for missing values (such as 
dots), you must still enter a numeric value in this field - preferably one that is well out 
of the usual range of data values. Upon opening the file, any non-numeric values 
(except in the first row) are treated as missing data. Missing values are not plotted and 
cannot be converted.

The "initialize with zeros" checkbox fills the output file with zeros initially, instead of 
with the “missing value” number. It is unchecked by default.



You can either apply the options to the current file by pressing the "Change current" 
button, or save the settings as defaults to be used every time by pressing the "Change 
all" button.

Keyboard shortcuts

The keyboard shortcuts for the File and Edit menus are standard, and are displayed in 
the menus. In the View menu, you can use + and - to zoom in and out.

The not-so-obvious shortcuts apply to the Tools menu:

M - Mode change
V - View change
I - Interpolate
C or F2 - Convert (F2 is included for historic reasons)
D or Backspace or Delete - delete selection
Esc - Break one-click baseline

The "secret" keys are:

Shift - use it to extend or contract the selection by shift-clicking
Left arrow and Right arrow - use them to move the right side of the selection 

by one point
Up arrow and Down arrow - use them to move the left side of the selection by 

one point

Converting data

- Automatic conversion

When set to automatic mode, BaseLiner analyzes and converts the entire file upon 
opening. However, unless you have perfect data, you will most likely need to do some 
manual tweaking. Bad data will need to be deleted, and the baseline adjusted if there 
are delta-T values crossing the baseline.

In this mode, the baseline points and the baseline itself are visible and editable. The 
no-flow conditions are marked with a white background, while the rest is gray.

This mode allows you to edit the baseline as well as the data.

- Editing the baseline:
The baseline points are clickable and moveable. Clicking on a point highlights it in 
yellow. A highlighted point can be moved by dragging or deleted by pressing "D" on 
the keyboard. New points can be added by double-clicking. As you make changes to 
the baseline in this manner, the data are automatically recalculated.

- Editing data:
You can delete, interpolate, or change values in this mode. For details, read the 
standard mode description below. As you edit data, output is automatically 
recalculated.



- Manual conversion

With BaseLiner in manual mode, nothing is converted upon opening a file. Only data 
that you select manually are converted. Therefore, if you have long sections of corrupt 
data, you need not bother deleting them. Just skip over them, and convert the good 
parts. By default, BaseLiner initializes your output file with "missing values", so that 
anything that you do not convert appears as a missing value in the output. This 
behavior can be changed in the Options, where you can choose to initialize your 
output with zeros. In this case, however, you will not be able to distinguish between 
missing data and actual measured zeros in the output.

While converting data, you can go back and reconvert any portion that has already 
been converted. If you make a bad selection and convert it, just redo the selection and 
convert again.

Before you convert the data, you need to establish the baseline. The baseline is always 
a straight line connecting the first and the last point in the selection.

For Granier sensors, the baseline is always above the data line, so that you need to 
make your selection from one high point to the next - usually one baseline per diurnal 
cycle, or one per several cycles, if their high points are approximately the same. If you 
are converting data that have the baseline below the data line, then you will select 
from one low point to the next.

Since selecting the high (or low) points is the most tedious part of the process, 
BaseLiner offers several features designed to make the process faster and easier. There 
are three operating modes, and each one offers some unique features.

The standard mode, which is always active at startup, allows you to make selections 
by clicking and dragging. As you do that, the values for the first and last point of the 
selection are displayed above the plot, along with the date and time (as long as you 
have your date and time columns correctly identified in the Options). The plots will 
auto-scroll if you drag past the window boundaries. You can select from left to right, or 
from right to left.

Once a selection has been made, you can delete the selected data, interpolate, or 
convert them, by making selections from the menu, by clicking the "Convert" button, 
or by using one of the keyboard shortcuts. You can also modify the selection by shift-
clicking - if you click outside of the selection, it will be expanded, if you click inside - 
it will be contracted. The left and right arrows on the keyboard will move the right end 
of the selection back and forth, the up and down arrows will move the left end.

Converting a selection starts a new selection past the last one. The new selection 
includes the same number of points as the previous one. A relatively fast mouse-free 
method of conversion is to use the left and right arrows to place the end of the new 
selection exactly where you want it, then hit "C" to convert and move the selection 
along. This works well if the distance between the high points is approximately equal.

Working in the traditional mode allows you to clean up your data by deleting or 
interpolating, but it is the slowest method for conversion.



The next mode is called one-click baseline. While in this mode, the cursor changes 
from a crosshair to an up-down arrow. As you move the mouse around the plot, you 
will see the value of the point currently under the cursor displayed in a pop-up box 
next to the cursor.

While in one-click mode, all you can do is convert data. To start a selection, click on 
the desired point in the plot. The cursor will then change to a cross-arrow. Move the 
cursor to where the selection should end, and click again. This click causes the 
selection to be made, and the selected data are instantly converted. The clicked point 
automatically becomes the beginning for the next selection.

Keep on clicking until you are finished. When you are ready to stop, hit the Escape 
key, or select "Break one-click baseline" from the Tools menu. The cursor becomes an 
up-down arrow once again, ready to begin a new selection at a different point. You 
will need to break the baseline if you encounter a section of bad data and want to skip 
over it. Switching back to standard mode will also break the baseline. However, 
switching between modes preserves your current selection, so that you can easily 
switch modes as needed.

The third mode is the sloppy one-click. It works exactly like the previous mode, 
except that it makes it easier to locate the high points. In this mode, a blue dot follows 
the cursor, but "gravitates" toward the high points. Clicking the mouse starts the 
selection where the blue dot is, not where the cursor is, so that you don't have to be so 
precise in your clicking.

If your baseline is below the data, make sure to uncheck the "Baseline is high" box at 
the bottom left corner of the window. This will cause the blue dot to gravitate toward 
the low points.

Changing values

Although not designed specifically for this purpose, BaseLiner allows you to edit data 
values one point at a time. To do this, right-click the desired point in the top pane. 
You can change the point's value in the dialog that appears. You can change either the 
input or the output value, depending on what you are viewing. In most cases, however, 
when dealing with small sections of corrupt data, it is better to use interpolation. You 
can change values while in any of the three conversion modes.

Saving files

To save a file, select “Save” from the File menu, or click the save-file button on the 
toolbar. If you try to close a file without saving it first, the program will ask you to do 
so.

It is recommended that you do not overwrite your source data file. Therefore, save your 
output file with a new name.

Before letting you save a file, BaseLiner will ask you which parts of the file you want 
to save. You can save the unconverted data, the baseline data, and the converted data, 
in any combination. If you are not completely finished with a file, you should save all 
three. It is important to keep the baseline data, in case you need to go back and 



recalculate your output. Anytime you save more than one type of data, BaseLiner will 
include a header line in the file, which enables it to read the file correctly next time.

Once you are completely finished, you can save just the converted data. You can 
choose to replace the missing values with dots if necessary. Unless you plan to open 
the output file in BaseLiner again, you do not need to include the header line.

Before you actually save a file, you should go back to the Labels dialog and make sure 
that everything is the way you want it. Any data columns that were not converted but 
need to appear in the output unchanged, must have their corresponding "Do not 
convert" checkboxes checked!

Additional information
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